Nanumi ImagePlus v1.22 Basic

Nanumi ImagePlus Doc
v1.22 Basic

소개:

본 제품은 ASP(Active Serve Pages), Visual Basic등에서 사용할 수 있는 이미지 처리 컴포넌트(ActiveX DLL)입니다.
Miscrosoft사에서 새롭게 적용되고 있는 GDI+ 라이브러리에 기반을 두고 있습니다.

본 컴포넌트의 새로운 정보나 샘플소스 등은 http://nanumi.net에서 얻으실 수 있습니다.

본 컴포넌트(Nanumi ImagePlus v1.22 Basic)에서의 주 기능입니다.

  • 각종 이미지 파일을 처리 할 수 있습니다.(JPG, GIF, BMP, PNG, TIF)
  • 이미지 크기를 재조정 할 수 있습니다.(Thumbnail 기능)
  • 각종 이미지 포맷(Format)을 변환시킬 수 있습니다.(From: JPG, GIF, BMP, PNG, TIF → To: JPG, GIF, BMP, PNG, TIF)
  • 이미지 회전변환이 가능합니다.(RotateFlip 속성)
  • 이미지 저장시 압축된 JPG파일을 생성 할 수 있습니다.(압축률 설정 기능)

이 컴포넌트를 이용한 이미지 축소 기능의 ASP 샘플 코드입니다.

Set Image = Server.CreateObject("Nanumi.ImagePlus")
Image.OpenImageFile "C:/photos/test.jpg"
Image.ChangeSize 100, 100
Image.SaveFile "C:/photos/new.jpg"
Image.Dispose
Set Image = Nothing

Version History

  • v1.1 (2003.09.03) : 리소스 소멸 관련 메서드 추가(Dispose())
  • v1.2 (2004.03.01) : 설치 gdipuls.dll 시스템 디렉토리에 위치, OverWrite속성에 대한 제한
  • v1.21 (2004.05.20) : OverWrite속성 보완
  • v1.22 (2004.08.13) : Anti-Aliasing 보완

Public 속성:
public 속성 AllowEnlarge | 해당 Image 개체가 크기조절(Resizing)될 때 확대가능 여부를 설정합니다. 기본값은 False입니다.
public 속성 Height | 로드된 Image 개체의 높이를 가져옵니다.
public 속성 ImageFormat | 저장될 Image 개체의 형식을 지정합니다. 기본값은 JPG입니다.
public 속성 KeepAspect | 현재 Image 개체의 가로 세로 비율을 Image 개체의 크기조절(Resizing)시 유지 할지를 설정합니다. 기본값은 True입니다.
public 속성 MaxHeight | Image 개체의 크기조절(Resizing)시 적용 가능한 최대 높이를 가져옵니다.
public 속성 MaxWidth | Image 개체의 크기조절(Resizing)시 적용 가능한 최대 너비를 가져옵니다.
public 속성 OverWrite | Image 개체를 저장 할 때 동일 파일 존재시 덮어쓰기 여부를 설정합니다. 기본값은 False입니다.
public 속성 RotateFlip | Image 개체를 회전하거나 대칭 이동하거나, 회전하여 대칭 이동합니다.
public 속성 Quality | JPG파일 저장시 압축률을 설정합니다. 1(최소)~100(최대). 기본값은 75입니다.
public 속성 Version | 컴포넌트(개체)의 현재 버젼을 가져옵니다.
public 속성 Width | Image 개체의 너비를 가져옵니다.

Public 메서드:
public 메서드 ChangeSize | 저장될 Image 개체의 높이와 너비를 설정합니다.
public 메서드 OpenImageFile | 지정된 파일에서 Image 개체를 만듭니다.
public 메서드 SaveFile | Image 개체를 지정된 형식으로 지정된 파일에 저장합니다.
public 메서드 Dispose | Image 개체의 리소스를 해제시킵니다. (v1.1에서 추가)

Image.AllowEnlarge

해당 Image 개체가 크기조절(Resizing) 될 때 확대 가능여부를 설정합니다. 기본값은 False입니다.

Remarks:

원본 이미지 보다 크기를 확대시키고자 할 경우 이 속성을 True로 설정해야 합니다.
이때 Image.KeepAspect 속성(비율고정)은 False이어야 합니다.

원본 이미지의 가로/세로의 비율이 2:1 이라면 크기 조절되는 이미지의 가로/세로 비율이 2:1로 설정됩니다.

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.AllowEnlarge = True
Image.KeepAspect = False
Image.ChangeSize(Image.Width*2, Image.Height*2)

Image Object

Image.Height / Image.Width

로드된 Image 개체의 높이와 너비를 가져옵니다.

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Response.Write "이미지 너비: " & CStr(Image.Width)& "<br>"
Response.Write "이미지 높이: " & CStr(Image.Height)& "<br>"

Image Object

Image.ImageFormat

저장될 Image 개체의 형식을 지정합니다. 기본값은 JPG입니다.

Remarks:

JPG, GIF, BMP, PNG, TIF 파일 포맷으로 저장이 가능합니다.
JPG파일 저장시는 압축률(Image.Quality)을 설정 할 수 있습니다. 1 ~ 100

  • JPEG 파일타입 : Image.ImageFormat = "JPG"
  • GIF 파일타입 : Image.ImageFormat = "GIF"
  • BMP 파일타입 : Image.ImageFormat = "BMP"
  • PNG 파일타입 : Image.ImageFormat = "PNG"
  • TIF 파일타입 : Image.ImageFormat = "TIF" or "TIFF"

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.SaveFile "C:/photos/new.jpg"

Image Object

Image.KeepAspect

현재 Image 개체의 가로 세로 비율을 Image 개체의 크기조절(Resizing)시 유지할지를 설정합니다. 기본값은 True입니다.

Example:

너비와 높이를 강제적으로 조절하는 경우(Image.KeepAspect = False)

Image.OpenImageFile "C:/photos/test.jpg"
ImageImage.KeepAspect = False
ImageImage.ChangeSize Image.Width/2, Image.Height

Image Object

Image.MaxWidth / Image.MaxHeight

Image 개체의 크기조절(Resizing)시 적용 가능한 최대 너비와 최대 높이를 가져옵니다.
버젼에 따라 변경될 수 있으며, 현재 버젼(v1.0)에서는 최대 너비와 최대 높이 값은 10,000 으로 지정되어 있습니다.

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Response.Write "MaxWidth: " & CStr(Image.MaxWidth)& "<br>"
Response.Write "MaxHeight: " & CStr(Image.MaxHeight)& "<br>"

Image Object

Image.OverWrite

Image 개체를 저장 할 때 동일 파일 존재시 덮어쓰기 여부를 설정합니다. 기본값은 False입니다.

Example:

다른 경로에 있는 동일 이름의 파일을 저장 시킬 경우입니다.
// Example #1:
Image.OpenImageFile "C:/photos/test.jpg"
Image.OverWrite = True
Image.ChangeSize 100, 100
Image.SaveFile "C:/photos2/test.jpg"

아래의 경우는 에러를 발생시킵니다.
// Example #2:
Image.OpenImageFile "C:/photos/test.jpg"
Image.OverWrite = False
Image.ChangeSize 100, 100
Image.SaveFile "C:/photos2/test.jpg"

Image Object

Image.RotateFlip

Image 개체를 회전하거나 대칭 이동하거나, 회전하여 대칭 이동합니다.

값 | 멤버 이름 | 설명
0 (defalut) | RotateNoneFlipNone | 회전 안 함과 대칭 이동 안 함을 지정합니다.
1 | Rotate90FlipNone | 대칭 이동 없는 90도 회전을 지정합니다.
2 | Rotate180FlipNone | 대칭 이동 없는 180도 회전을 지정합니다.
3 | Rotate270FlipNone | 대칭 이동 없는 270도 회전을 지정합니다.
4 | RotateNoneFlipX | 수평 대칭 이동 후 회전 안 함을 지정합니다.
5 | Rotate90FlipX | 수평 대칭 이동 후 90도 회전을 지정합니다.
6 | Rotate180FlipX | 수평 대칭 이동 후 180도 회전을 지정합니다.
7 | Rotate270FlipX | 수평 대칭 이동 후 270도 회전을 지정합니다.

Example:

시계방향으로 90°회전(Rotate90FlipNone)하는 경우입니다.

Image.OpenImageFile "C:/photos/test.jpg"
Image.RotateFlip = 1
Image.ChangeSize 100, 100
Image.SaveFile "C:/photos/new.jpg"

Image Object

Image.Quality

JPG파일 저장시 압축률을 설정합니다. 1(최대압축)~100(최소압축). 기본값은 75입니다.

Remarks:

Quality의 수치가 낮을수록 생성되는 JPG파일의 용량은 작아지나, 이미지의 훼손은 증가하게 됩니다.

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.Quality = 100
Image.SaveFile "C:/photos/new.jpg"

Image Object

Image.Version

컴포넌트(개체)의 현재 버젼을 가져옵니다.

Example:

Set Image = Server.CreateObject("Nanumi.ImagePlus")
Response.Write "현재 버젼: " & Image.Version
Set Image = Nothing

Image Object

Image.ChangeSize()

저장될 Image 개체의 너비와 높이를 설정합니다.

Syntax:
Object.ChageSize NewWidth, NewHeight

Parameters:

NewWidth | 재조정 될 너비
NewHeight | 재조정 될 높이

Example:

한개의 원본 이미지로부터 한개의 썸네일 이미지를 생성하는 경우
Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.Quality = 100
Image.ChangeSize 150,150
Image.SaveFile "C:/photos/new.jpg"

한개의 원본 이미지로부터 두개의 썸네일 이미지를 생성하는 경우
// Example #1:
Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.Quality = 100
Image.ChangeSize 150,150
Image.SaveFile "C:/photos/new01.jpg"
Image.ChangeSize 400,400
Image.SaveFile "C:/photos/new02.jpg"

 // Example #2:
Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.Quality = 100
Image.ChangeSize 150,150
Image.SaveFile "C:/photos/new01.jpg"

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.Quality = 100
Image.ChangeSize 400,400
Image.SaveFile "C:/photos/new02.jpg"

Image Object

Image.OpenImageFile()

지정된 파일에서 Image 개체를 만듭니다.

Syntax:
Object.OpenImageFile ImageName

Parameters:

ImageName 지정된 경로와 파일이름 예: "C:/photos/new02.jpg"

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.SaveFile "C:/photos/new.jpg"

Image Object

Image.SaveFile()

Image 개체를 지정된 형식(Image.ImageFormat)으로 지정된 파일에 저장합니다.

Syntax:
Object.SaveFile ImageName

Parameters:

ImageName 지정된 경로와 파일이름 예: "C:/photos/new02.jpg"

Remarks:

지정된 경로에 해당 폴더가 존재하지 않을 경우는 에러를 발생시킵니다. 메모리에 로드된 이미지가 아닌 다른 경로에 같은 이름의 파일이 존재할 경우는 Image.OverWrite속성에 의해 덮어쓰기 여부가 결정됩니다.

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.SaveFile "C:/photos/new.jpg"

Image Object

Image.Dispose()

해당 Image객체가 사용했던 리소스를 해제시킵니다.

Syntax:
Object.Dispose

Example:

Image.OpenImageFile "C:/photos/test.jpg"
Image.ImageFormat = "JPG"
Image.SaveFile "C:/photos/new.jpg"
Image.Dispose

Image Object

Copyright (c) 2001~2004 NANUMI.NET All rights reserved